using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(~(?(?=.*?~~.*?~).*?~.*?~.*?~|[^~]+?~))";
string input = @"~The ~spectacle~~ was ~borken~, but that was not the same ~spectacle~
that was given to ~me~.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}