re = /(~(?(?=.*?~~.*?~).*?~.*?~.*?~|[^~]+?~))/
str = '~The ~spectacle~~ was ~borken~, but that was not the same ~spectacle~
that was given to ~me~.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end