const regex = /^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){3}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([01]?\\d?\\d|2[0-4]\\d|25[0-5])\\.){3}$', '')
const str = `255.145.246.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}