import re
regex = re.compile(r"^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){3}$")
test_str = "255.145.246."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")