$re = '/^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){3}$/';
$str = '255.145.246.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);