import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?([A-Z]{2,3}),.*";
final String string = "338-340 Tapleys Hill Rd, Seaton SA, Australia\n"
+ "55 Christie St, St Leonards NSW, Australia\n"
+ "Kincumber South NSW, Australia";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}