re = /.*?([A-Z]{2,3}),.*/
str = '338-340 Tapleys Hill Rd, Seaton SA, Australia
55 Christie St, St Leonards NSW, Australia
Kincumber South NSW, Australia'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end