$re = '/.*?([A-Z]{2,3}),.*/';
$str = '338-340 Tapleys Hill Rd, Seaton SA, Australia
55 Christie St, St Leonards NSW, Australia
Kincumber South NSW, Australia';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);