import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=['\"])\\d+\\.jpg";
final String string = "<html>\n\n"
+ "<body>\n"
+ "<a href='1.jpg'><img src='tn1.jpg /></a>\n"
+ "<a href='2.jpg'><img src='tn2.jpg /></a>\n"
+ "<a href='3.jpg'><img src='tn3.jpg /></a>\n"
+ "<a href='4.jpg'><img src='tn4.jpg /></a>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}