$re = '/(?<=[\'"])\d+\.jpg/';
$str = '<html>
<body>
<a href=\'1.jpg\'><img src=\'tn1.jpg /></a>
<a href=\'2.jpg\'><img src=\'tn2.jpg /></a>
<a href=\'3.jpg\'><img src=\'tn3.jpg /></a>
<a href=\'4.jpg\'><img src=\'tn4.jpg /></a>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);