use strict;
my $str = '<html>
<body>
<a href=\'1.jpg\'><img src=\'tn1.jpg /></a>
<a href=\'2.jpg\'><img src=\'tn2.jpg /></a>
<a href=\'3.jpg\'><img src=\'tn3.jpg /></a>
<a href=\'4.jpg\'><img src=\'tn4.jpg /></a>
</body>
</html>';
my $regex = qr/(?<=['"])\d+\.jpg/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}