package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:ISO|ASTM\s*D)(?:[\s-]*\d)+`)
var str = `ISO 527-1, ASTM D143, DIN EN ISO 3349-3, and ASTM D143 are all testing standards. ISO 31 33, ISO 334 9 are specific to static bending, but ASTM D 149-3 includes various other 9. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}