re = /(?:ISO|ASTM\s*D)(?:[\s-]*\d)+/m
str = 'ISO 527-1, ASTM D143, DIN EN ISO 3349-3, and ASTM D143 are all testing standards. ISO 31 33, ISO 334 9 are specific to static bending, but ASTM D 149-3 includes various other 9. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end