import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:ISO|ASTM\\s*D)(?:[\\s-]*\\d)+";
final String string = "ISO 527-1, ASTM D143, DIN EN ISO 3349-3, and ASTM D143 are all testing standards. ISO 31 33, ISO 334 9 are specific to static bending, but ASTM D 149-3 includes various other 9. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}