import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*(?:(?!\\*/|/\\*).)*\\R(?s).*?\\*/";
final String string = "/* comment */ not a comment /* another comment */\n\n"
+ "/* delete this *\n"
+ "/* multiline *\n"
+ "/* comment */\n\n"
+ "/*************\n"
+ "/* and this * \n"
+ "/************/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}