re = /\/\*(?:(?!\*\/|\/\*).)*\R(?s).*?\*\//
str = '/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end