use strict;
my $str = '200\'11"
392\'11"
92\'3"
2000\'11"
2000\'10"
2000\'1"
2000"
2000\'13"
3000\'11"
2000\'12"
';
my $regex = qr/^([1-2]?[0-9]{1,3})\'([0-9]|[0-1]{2})\"$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}