using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[!%&'\(\)\*\+\-\.\/;<=>\?\\,:#@\t\r\n""\[\]_]";
string input = @"test ! % & \ ' ( ) * + - . / ; < = > ? \\ , : # @ \t \r \n "" [] _ test";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}