package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[!%&'\(\)\*\+\-\.\/;<=>\?\\,:#@\t\r\n"\[\]_]`)
var str = `test ! % & \ ' ( ) * + - . / ; < = > ? \\ , : # @ \t \r \n " [] _ test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}