re = /[!%&'\(\)\*\+\-\.\/;<=>\?\\,:#@\t\r\n"\[\]_]/
str = 'test ! % & \\ \' ( ) * + - . / ; < = > ? \\\\ , : # @ \\t \\r \\n " [] _ test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end