#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!_?config|packages).*\/(?!(app|web|packages|repositories)\.)[^\/]*config$"
Local $sString = "Web/smtp.config" & @CRLF & _
"Libraries/Data/connectionStrings.config" & @CRLF & _
"_config/staging/smtp.config" & @CRLF & _
"Web/web.config" & @CRLF & _
"Web/web.release.config" & @CRLF & _
"Web/Views/web.config" & @CRLF & _
"Libraries/Data/app.config" & @CRLF & _
"Libraries/Data/packages.config" & @CRLF & _
"Data/app.config" & @CRLF & _
"packages/MiniProfiler.EF6.3.0.11/lib/net40/MiniProfiler.EntityFramework6.dll.config" & @CRLF & _
"packages/repositories.config" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")