# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!_?config|packages).*\/(?!(app|web|packages|repositories)\.)[^\/]*config$"
test_str = ("Web/smtp.config\n"
"Libraries/Data/connectionStrings.config\n"
"_config/staging/smtp.config\n"
"Web/web.config\n"
"Web/web.release.config\n"
"Web/Views/web.config\n"
"Libraries/Data/app.config\n"
"Libraries/Data/packages.config\n"
"Data/app.config\n"
"packages/MiniProfiler.EF6.3.0.11/lib/net40/MiniProfiler.EntityFramework6.dll.config\n"
"packages/repositories.config\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.