$re = '/^(?!_?config|packages).*\/(?!(app|web|packages|repositories)\.)[^\/]*config$/mi';
$str = 'Web/smtp.config
Libraries/Data/connectionStrings.config
_config/staging/smtp.config
Web/web.config
Web/web.release.config
Web/Views/web.config
Libraries/Data/app.config
Libraries/Data/packages.config
Data/app.config
packages/MiniProfiler.EF6.3.0.11/lib/net40/MiniProfiler.EntityFramework6.dll.config
packages/repositories.config
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);