package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b[^\d\W]+\b\s?){3}`)
var str = `start 5 one two three 7 end
start 5 one 2 two three 7 end
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}