$re = '/(\b[^\d\W]+\b\s?){3}/';
$str = 'start 5 one two three 7 end
start 5 one 2 two three 7 end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);