const regex = /(\b[^\d\W]+\b\s?){3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b[^\\d\\W]+\\b\\s?){3}', 'g')
const str = `start 5 one two three 7 end
start 5 one 2 two three 7 end
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}