const regex = /(\d{3}(?!,))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3}(?!,))', 'gm')
const str = `8888888`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);