use strict;
my $str = '8888888';
my $regex = qr/(\d{3}(?!,))/mp;
my $subst = '$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";