$re = '/(\d{3}(?!,))/m';
$str = '8888888';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;