package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?<suffix>\d{4}-\d{2}-\d{2}).)?api.com$`)
var str = `2021-01-01.api.com
api.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}