$re = '/^((?<suffix>\d{4}-\d{2}-\d{2}).)?api.com$/m';
$str = '2021-01-01.api.com
api.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);