re = /^((?<suffix>\d{4}-\d{2}-\d{2}).)?api.com$/m
str = '2021-01-01.api.com
api.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end