#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=[^)]*(?:[(]|$))"
Local $sString = "rttr,ertrret,ertret(yes,no),ete(,)ert,ert ert,rtrter,0" & @CRLF & _
"rttr,ert(yes,no)rret,ert ret,eteert,ertert,rtrter,1" & @CRLF & _
"rttr,ertrret,ert ret,eteert,ertert,rtrter,0" & @CRLF & _
"rttr,ertrret,ert ret,eteert,ertert,rtrter,2 " & @CRLF & _
"rttr,ert(white,black)rret,ert ret,eteert,ertert,rtrter,0" & @CRLF & _
"rttr,ertrret,ert ret,eteert,ertert,rtrter,0" & @CRLF & _
"rttr,ertrret,ert ret,et(blue,green,yellow,orange,white)eert,ertert,rtrter,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")