# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",(?=[^)]*(?:[(]|$))"
test_str = ("rttr,ertrret,ertret(yes,no),ete(,)ert,ert ert,rtrter,0\n"
"rttr,ert(yes,no)rret,ert ret,eteert,ertert,rtrter,1\n"
"rttr,ertrret,ert ret,eteert,ertert,rtrter,0\n"
"rttr,ertrret,ert ret,eteert,ertert,rtrter,2 \n"
"rttr,ert(white,black)rret,ert ret,eteert,ertert,rtrter,0\n"
"rttr,ertrret,ert ret,eteert,ertert,rtrter,0\n"
"rttr,ertrret,ert ret,et(blue,green,yellow,orange,white)eert,ertert,rtrter,1")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.