import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=[^)]*(?:[(]|$))";
final String string = "rttr,ertrret,ertret(yes,no),ete(,)ert,ert ert,rtrter,0\n"
+ "rttr,ert(yes,no)rret,ert ret,eteert,ertert,rtrter,1\n"
+ "rttr,ertrret,ert ret,eteert,ertert,rtrter,0\n"
+ "rttr,ertrret,ert ret,eteert,ertert,rtrter,2 \n"
+ "rttr,ert(white,black)rret,ert ret,eteert,ertert,rtrter,0\n"
+ "rttr,ertrret,ert ret,eteert,ertert,rtrter,0\n"
+ "rttr,ertrret,ert ret,et(blue,green,yellow,orange,white)eert,ertert,rtrter,1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}