re = /^(([^f]|f([^io]|o([^r]|r[a-z])|i([^ln]|l([^e]|e[a-z])|n([^d]|d[a-z]))))[a-z]*|(f(o|i|i(l|n))))?$/
str = 'fo'
# Print the match result
str.match(re) do |match|
puts match.to_s
end