// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(([^f]|f([^io]|o([^r]|r[a-z])|i([^ln]|l([^e]|e[a-z])|n([^d]|d[a-z]))))[a-z]*|(f(o|i|i(l|n))))?$").unwrap();
let string = "fo";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}