# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\..*$(*SKIP)(*F)|(?!^)(?=(?:\d{3})+(?=\.|$))/ /gm;t' <<< "999999999
33333.25
222.32
4444
0.12345678"