import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\..*$(*SKIP)(*F)|(?!^)(?=(?:\\d{3})+(?=\\.|$))";
final String string = "999999999\n"
+ "33333.25\n"
+ "222.32\n"
+ "4444\n"
+ "0.12345678";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}