#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:(?!Files:).)+|\s*-----THIS STUFF IS USELESS-----.+"
Local $sString = "Blah blah blah" & @CRLF & _
"Foobar foo foo" & @CRLF & _
"" & @CRLF & _
"Files:" & @CRLF & _
" somefiles.tar.gz 1 2 3" & @CRLF & _
" somefiles.tar.gz 1 2 3" & @CRLF & _
"" & @CRLF & _
"-----THIS STUFF IS USELESS-----" & @CRLF & _
"BLEH BLEH BLEH" & @CRLF & _
"BLEH BLEH BLEH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")