re = /^(?:(?!Files:).)+|\s*-----THIS STUFF IS USELESS-----.+/
str = 'Blah blah blah
Foobar foo foo
Files:
somefiles.tar.gz 1 2 3
somefiles.tar.gz 1 2 3
-----THIS STUFF IS USELESS-----
BLEH BLEH BLEH
BLEH BLEH BLEH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end