const regex = /^(?:(?!Files:).)+|\s*-----THIS STUFF IS USELESS-----.+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!Files:).)+|\\s*-----THIS STUFF IS USELESS-----.+', 'g')
const str = `Blah blah blah
Foobar foo foo
Files:
somefiles.tar.gz 1 2 3
somefiles.tar.gz 1 2 3
-----THIS STUFF IS USELESS-----
BLEH BLEH BLEH
BLEH BLEH BLEH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}