using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.+)(?=\, \d+?(st|nd|rd|th))|\((.+)(?=\, \d+?\))";
string input = @"Title (Author, 2nd Ed, 2000)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}