$re = '/\((.+)(?=\, \d+?(st|nd|rd|th))|\((.+)(?=\, \d+?\))/';
$str = 'Title (Author, 2nd Ed, 2000)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);