re = /\((.+)(?=\, \d+?(st|nd|rd|th))|\((.+)(?=\, \d+?\))/
str = 'Title (Author, 2nd Ed, 2000)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end