package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(;)`)
var str = `DELETE FROM import WHERE NOT recstatus;
ALTER TABLE import DROP COLUMN IF EXISTS erreur;
ALTER TABLE import ADD COLUMN erreur TEXT;
DROP TRIGGER IF EXISTS line_error_seek_trigger ON import;
DROP FUNCTION IF EXISTS line_error_seek();
CREATE OR REPLACE FUNCTION line_error_seek() RETURNS TRIGGER AS $errors_by_line$
BEGIN
blabla;
blablabla;
IF blabla
bla blaaaaaa;
END IF;
RETURN bla;
END;
$errors_by_line$ language 'plpgsql';
CREATE TRIGGER line_error_seek_trigger
BEFORE UPDATE ON import
FOR EACH ROW
EXECUTE PROCEDURE line_error_seek();
DROP FUNCTION IF EXISTS table_error_seek();
CREATE OR REPLACE FUNCTION table_error_seek() RETURNS INTEGER AS $errors_by_table$
BEGIN
blabla;
blablabla;
RETURN bla;
END;
$errors_by_table$ LANGUAGE plpgsql;
SELECT * FROM table_error_seek();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}