import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(;)";
final String string = "DELETE FROM import WHERE NOT recstatus;\n\n"
+ "ALTER TABLE import DROP COLUMN IF EXISTS erreur;\n"
+ "ALTER TABLE import ADD COLUMN erreur TEXT;\n\n"
+ "DROP TRIGGER IF EXISTS line_error_seek_trigger ON import;\n"
+ "DROP FUNCTION IF EXISTS line_error_seek();\n\n"
+ "CREATE OR REPLACE FUNCTION line_error_seek() RETURNS TRIGGER AS $errors_by_line$\n"
+ "BEGIN\n"
+ " blabla;\n"
+ " blablabla;\n"
+ " IF blabla\n"
+ " bla blaaaaaa;\n"
+ " END IF;\n"
+ " RETURN bla;\n"
+ "END;\n"
+ "$errors_by_line$ language 'plpgsql';\n\n"
+ "CREATE TRIGGER line_error_seek_trigger\n"
+ " BEFORE UPDATE ON import\n"
+ " FOR EACH ROW\n"
+ " EXECUTE PROCEDURE line_error_seek();\n\n"
+ "DROP FUNCTION IF EXISTS table_error_seek();\n\n"
+ "CREATE OR REPLACE FUNCTION table_error_seek() RETURNS INTEGER AS $errors_by_table$\n"
+ "BEGIN\n"
+ " blabla;\n"
+ " blablabla;\n"
+ " RETURN bla;\n"
+ "END;\n"
+ "$errors_by_table$ LANGUAGE plpgsql;\n\n"
+ "SELECT * FROM table_error_seek();";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}