import Foundation
let pattern = #"(;)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
DELETE FROM import WHERE NOT recstatus;
ALTER TABLE import DROP COLUMN IF EXISTS erreur;
ALTER TABLE import ADD COLUMN erreur TEXT;
DROP TRIGGER IF EXISTS line_error_seek_trigger ON import;
DROP FUNCTION IF EXISTS line_error_seek();
CREATE OR REPLACE FUNCTION line_error_seek() RETURNS TRIGGER AS $errors_by_line$
BEGIN
blabla;
blablabla;
IF blabla
bla blaaaaaa;
END IF;
RETURN bla;
END;
$errors_by_line$ language 'plpgsql';
CREATE TRIGGER line_error_seek_trigger
BEFORE UPDATE ON import
FOR EACH ROW
EXECUTE PROCEDURE line_error_seek();
DROP FUNCTION IF EXISTS table_error_seek();
CREATE OR REPLACE FUNCTION table_error_seek() RETURNS INTEGER AS $errors_by_table$
BEGIN
blabla;
blablabla;
RETURN bla;
END;
$errors_by_table$ LANGUAGE plpgsql;
SELECT * FROM table_error_seek();
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)