package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(((copyright)\s)?)((©|\(c\))?[^(\(|\;|\{)])`)
var str = `Copyright ©
copyright ©
copyright (c)
Copyright (C)
copyright (C)
Copyright (c)
Copyright ©
copyright ©
copyright
(c)
function (c);
(C) {
(c);
function (c){
(C){
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}