import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*\\sheadline(?:(?!^\\*\\sheadline).)*:END:$";
final String string = "* headline 0\n"
+ "* headline 1\n"
+ " :PROPERTIES:\n"
+ " :KEY: lala\n"
+ " :END:\n"
+ "* headline 2\n"
+ "* headline 3\n"
+ " :PROPERTIES:\n"
+ " :KEY: lblb\n"
+ " :END:\n"
+ "* headline 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}